IM 7.0.8-16 - Problem with mpr: index numbers

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GeeMack
Posts: 678
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

IM 7.0.8-16 - Problem with mpr: index numbers

Post by GeeMack » 2018-12-13T18:23:36-07:00

Using ImageMagick 7.0.8-16 Q16 x64 HDRI on Windows. There seems to be a problem accessing an "mpr:" memory register by index number. When running this command...

Code: Select all

magick -size 32x32 xc:red xc:lime xc:blue -write mpr:test -delete 0--1 mpr:test[0] out.png
... the output should be a single red square read from "mpr:test[0]". Instead it outputs all three images, the red, lime, and blue. The same failure occurs when using any combination of index numbers inside the square brackets like "mpr:test[N]", "mpr:test[N-N]", "mpr:test[N,N]". The output in every case is all the images that were written to the "mpr:". There are no errors or warnings, even if using an index number beyond the number of images in the "mpr:" list.

User avatar
fmw42
Posts: 24764
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: IM 7.0.8-16 - Problem with mpr: index numbers

Post by fmw42 » 2018-12-13T20:58:13-07:00

I get the same behavior on IM 7.0.8.16 Mac OSX Sierra. It also fails on IM 6.9.10.16 Q16 for me.

User avatar
magick
Site Admin
Posts: 10935
Joined: 2003-05-31T11:32:55-07:00

Re: IM 7.0.8-16 - Problem with mpr: index numbers

Post by magick » 2018-12-15T10:34:21-07:00

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ https://www.imagemagick.org/download/beta/ by sometime tomorrow.

User avatar
GeeMack
Posts: 678
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Re: IM 7.0.8-16 - Problem with mpr: index numbers

Post by GeeMack » 2018-12-19T08:08:22-07:00

This issue appears to be resolved with version 7.0.8-17. Thanks!

Post Reply