Page 1 of 1

Cannot locate header file MagickWand.h during imagick configuring

Posted: 2019-06-28T11:09:00-07:00
by Ubamazive
I'm trying to install ImageMagick and imagick on my Centos 7 box. This box is running directadmin, hence I thought this might be a good place to start.

I've searched on google for an hour or so, and I can't really find anything that solves this.

# Wand-config --version
6.8.3 Q16
]# convert --version

Version: ImageMagick 7.0.8

Kernel 5.1.15

I have installed this ImageMagick the following way:
# yum install ImageMagick.x86_64 ImageMagick-devel.x86_64

I've also tried it without the x86_64 on the end, and it installed both (also i386). But the problem still occured.

When I download imagick from source, untar it, use phpize and then configure I get the following error:

checking for MagickWand.h header file... configure: error: Cannot locate header file MagickWand.h

If I use pecl (pecl install imagick) I get the same error as well.

Strangely enough, MagickWand.h is on my system. It's in 2 directories:


I hope one of you guys recognizes this problem and give me some pointers