OpenCL can't be disabled in ImageMagick-6.9.10-66

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
volkerdi
Posts: 2
Joined: 2019-09-27T18:15:08+00:00
Authentication code: 1152

OpenCL can't be disabled in ImageMagick-6.9.10-66

Post by volkerdi »

Good hello, this is Slackware maintainer Patrick Volkerding.

One of our users, Markus Wiesner, reported a bug regarding the latest
version of ImageMagick-6, so I'm passing it along. Sometime after
ImageMagick-6.9.10-63 the handling of configure options for OpenCL
changed, and now the binaries are linking to libOpenCL in spite of
--disable-opencl (or --enable-opencl=no).
User avatar
magick
Site Admin
Posts: 11064
Joined: 2003-05-31T18:32:55+00:00

Re: OpenCL can't be disabled in ImageMagick-6.9.10-66

Post by magick »

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ http://www.imagemagick.org/download/beta/ by sometime tomorrow.
volkerdi
Posts: 2
Joined: 2019-09-27T18:15:08+00:00
Authentication code: 1152

Re: OpenCL can't be disabled in ImageMagick-6.9.10-66

Post by volkerdi »

You're welcome! Thanks for the quick response.
Post Reply