ImageMagick never found in @INC

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
Posts: 1
Joined: 2019-07-22T00:47:32-07:00
Authentication code: 1152

ImageMagick never found in @INC

Post by sergioq »

I have Ubuntu 18.04, Perl v5.26.1 and no matter how many ways I've tried to install Image::Magick it never is part of @INC so I am unable to use it in my CGI scripts.

It appears I've installed ImageMagick-7.0.8-53 going by the directory. But every time I run
cpan install PerlMagick
the error I see is:
In file included from /usr/include/ImageMagick-6/magick/MagickCore.h:29:0,
from Magick.xs:60:
/usr/include/ImageMagick-6/magick/magick-config.h:21:10: fatal error: magick/magick-baseconfig.h: No such file or directory
#include "magick/magick-baseconfig.h"
compilation terminated.
Makefile:347: recipe for target 'Magick.o' failed
make: *** [Magick.o] Error 1
make -- NOT OK
There seems to be an error discrepency as it mentions ImageMagick-6, but I am too new to installs on linux to figure this out. I've googled more than ever before.

Woudl appreciate any help,

Post Reply