Backslashes in -set profile

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
snibgo
Posts: 11447
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Backslashes in -set profile

Post by snibgo » 2018-12-16T15:12:16-07:00

Windows 8.1, IM v7.0.7-28.

Backslashes work in "-profile", but they are ignored in "-set profile".

Code: Select all

magick xc: -profile \web\im\sRGB.icc NULL:
... Works fine.

This fails:

Code: Select all

magick xc: -set profile \web\im\sRGB.icc NULL:

magick: unable to open file 'webimsRGB.icc': No such file or directory @ error/blob.c/FileToBlob/1304.
snibgo's IM pages: im.snibgo.com

User avatar
fmw42
Posts: 24737
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Backslashes in -set profile

Post by fmw42 » 2018-12-16T15:18:37-07:00

Just checking and forward slashes work fine on my Mac.

Code: Select all

magick xc: -set profile /Users/fred/images/profiles/sRGB.icc NULL:

snibgo
Posts: 11447
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Backslashes in -set profile

Post by snibgo » 2018-12-16T16:23:34-07:00

In Windows, "-set profile" works fine with forward slashes. But backslashes are interpreted, eg backslash-n is interpreted as newline:

Code: Select all

f:\web\im>%IMG7%magick xc: -set profile \web\nim\sRGB.icc NULL:

magick: unable to open file 'web
imsRGB.icc': Invalid argument @ error/blob.c/FileToBlob/1304.
That interpretation (correctly) doesn't occur in "-profile".
snibgo's IM pages: im.snibgo.com

Post Reply