picturefold script from fred

A plethora of command-line scripts that perform geometric transforms, blurs, sharpens, edging, noise removal, and color manipulations.
Post Reply
Posts: 6
Joined: 2018-06-04T19:34:05+00:00
Authentication code: 1152

picturefold script from fred

Post by pim »

I am a absolute beginner with IM.
Just tried two scripts from Fred: stainedglass worked - picturefold dind't

My system:
Ubuntu 18.04 LTS
Version: ImageMagick 6.9.7-4 Q16 x86_64 20170114

And here what I get:
-> no output image map.jpg is produced at all...

Code: Select all

>> picturefold.sh -n 5 ~/Downloads/birdofparadise/cartoon-parrot.jpg ~/Downloads/birdofparadise/map.jpg
convert-im6.q16: DistributedPixelCache '' @ error/distribute-cache.c/ConnectPixelCacheServer/244.
convert-im6.q16: cache resources exhausted `/tmp/picturefold_1_3913.mpc' @ error/cache.c/OpenPixelCache/3982.
convert-im6.q16: unable to persist pixel cache `/tmp/picturefold_1_3913.mpc' @ error/mpc.c/ReadMPCImage/963.
convert-im6.q16: no such image `black' @ error/mogrify.c/MogrifyImageList/8770.
convert-im6.q16: no images defined `/tmp/picturefold_1_3913.mpc' @ error/convert.c/ConvertImageCommand/3258.
Any idea why I observe such a strange beaviour?

Cheers, pim

PS. I already created this topic and Fred advised me to ask here in the bugs section:
https://www.imagemagick.org/discourse- ... 6&t=34079
User avatar
Posts: 25562
Joined: 2007-07-03T00:14:51+00:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: picturefold script from fred

Post by fmw42 »

He says it works for one image, but not another. It looks like some imagemagick issue or cache being exhausted. But I am not sure what the error message actually means.
User avatar
Site Admin
Posts: 11064
Joined: 2003-05-31T18:32:55+00:00

Re: picturefold script from fred

Post by magick »

Its likely the script is trying, likely improperly, to create a huge intermediate image. ImageMagick first tries to create the pixel cache in memory. That fails so it tries allocating the pixel cache on disk. That fails so it tried the distributed cache. Since its not configured, ImageMagick gives up and throws an exception. Trace the script and find our where and why the image resource request is blowing up.
Post Reply