label:@-

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GreenKoopa
Posts: 457
Joined: 2010-11-04T17:24:08-07:00
Authentication code: 8675308

label:@-

Post by GreenKoopa » 2014-01-22T23:09:34-07:00

Something about newlines when using label:@- is causing a problem. Is this expected? Does this happen only on Windows?

Test 1-4 work as expected. Tests 5 & 6 give the error:
convert.exe: unable to read blob `-': No such file or directory @ error/blob.c/FileToBlob/1055.
If -size is specified for case 5 & 6, IM hangs.

Code: Select all

convert label:@"single.txt" test1.png
convert label:@- test2.png < "single.txt"
type "single.txt" | convert label:@- test3.png
convert label:@"multi.txt" test4.png
convert label:@- test5.png < "multi.txt"
type "multi.txt" | convert label:@- test6.png
ImageMagick 6.8.8-1 Q16 x64 2013-12-25 on Windows 7

User avatar
fmw42
Posts: 25761
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: label:@-

Post by fmw42 » 2014-01-23T00:01:58-07:00

try

convert label:"@single.txt" test1.png

or

convert label:@single.txt test1.png

User avatar
GreenKoopa
Posts: 457
Joined: 2010-11-04T17:24:08-07:00
Authentication code: 8675308

Re: label:@-

Post by GreenKoopa » 2014-01-23T00:40:42-07:00

Yes, Windows is weird about quotes. But they are not the problem this time.

label:@filename reads from a file correctly (cases 1 & 4)
label:@- reads from a pipe correctly (cases 2 & 3)
label: handles newlines properly. (case 4, and as a direct string)
but when @- and newlines are mixed, nothing good happens (cases 5 & 6)

snibgo
Posts: 12433
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: label:@-

Post by snibgo » 2014-01-23T02:44:59-07:00

Problem confirmed for IM v6.8.8-0 on Windows 8.1.
snibgo's IM pages: im.snibgo.com

User avatar
dlemstra
Posts: 1587
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: label:@-

Post by dlemstra » 2014-01-24T03:26:31-07:00

We are working on a fix. This is a windows only problem and will be fixed in ImageMagick 6.8.8-3.
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

Post Reply