6.8.6-10 32bit DLL compile not working under XP64

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
henrywho
Posts: 188
Joined: 2011-08-17T06:46:40-07:00
Authentication code: 8675308

6.8.6-10 32bit DLL compile not working under XP64

Post by henrywho » 2013-09-20T20:53:03-07:00

ImageMagick-6.8.6-10-Q16-x86-dll.exe (18,305,076 bytes)

"The procedure entry point GetErrorMode could not be located in the dynamic link library KERNEL32.dll."

User avatar
dlemstra
Posts: 1567
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: 6.8.6-10 32bit DLL compile not working under XP64

Post by dlemstra » 2013-09-21T02:17:03-07:00

This error was also reported here: viewtopic.php?f=1&t=24124. I submitted a patch to fix this problem. This problem does not happen with Windows Vista / Windows Server 2008 or higher.
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

henrywho
Posts: 188
Joined: 2011-08-17T06:46:40-07:00
Authentication code: 8675308

Re: 6.8.6-10 32bit DLL compile not working under XP64

Post by henrywho » 2013-09-21T09:09:37-07:00

Too bad that the support of 64bit compile under XP64 had been dropped ....

User avatar
dlemstra
Posts: 1567
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: 6.8.6-10 32bit DLL compile not working under XP64

Post by dlemstra » 2013-09-21T10:46:02-07:00

The support has not been dropped, sorry for the misunderstanding. We fixed this issue and it will be resolved in the next release.
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

Post Reply