php-imagick installed but not working on Ubuntu 19.04 Disco / Nginx 1.15.12 / PHP 7.3.4-1+ubuntu19.04.1+deb.sury.org+3

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
sudoranger
Posts: 2
Joined: 2019-04-22T19:44:54-07:00
Authentication code: 1152

php-imagick installed but not working on Ubuntu 19.04 Disco / Nginx 1.15.12 / PHP 7.3.4-1+ubuntu19.04.1+deb.sury.org+3

Post by sudoranger » 2019-04-22T19:55:06-07:00

Code: Select all

sudo apt install php-imagick
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php-imagick is already the newest version (3.4.3~rc2-2ubuntu6).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Code: Select all

php -m | grep imagick
returns nothing. In my WordPress Health Check plugin, it says:
The optional module, imagick, is not installer, or has been disabled.
Imagick Module Version Imagick not available
ImageMagick Version Imagick not available
I can't find it in my phpinfo(); either. For now, I'm not sure if this is a Disco problem or Sury repository issue (ondrej's ppa) but first I would like to know what you have to say. It's working fine on 18.04.2 bionic with sury's repo though. Thanks!

Some references...

1. https://launchpad.net/ubuntu/+source/php7.3
2. https://launchpad.net/~ondrej/+archive/ubuntu/php/
php-imagick 3.4.3-4+ubuntu18.10.1+deb.sury.org+1 Ondřej Surý (2018-10-15)
php-imagick 3.4.3-4+ubuntu18.04.1+deb.sury.org+1 Ondřej Surý (2018-10-15)
php-imagick 3.4.3-4+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2018-10-15)

User avatar
fmw42
Posts: 25259
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: php-imagick installed but not working on Ubuntu 19.04 Disco / Nginx 1.15.12 / PHP 7.3.4-1+ubuntu19.04.1+deb.sury.org

Post by fmw42 » 2019-04-22T20:47:03-07:00

Did you install ImageMagick first? Imagick require ImageMagick. This is an ImageMagick forum, not specifically for Imagick. But there is a subform for Imagick, below. The ImageMagick developers do not maintain Imagick.

sudoranger
Posts: 2
Joined: 2019-04-22T19:44:54-07:00
Authentication code: 1152

Re: php-imagick installed but not working on Ubuntu 19.04 Disco / Nginx 1.15.12 / PHP 7.3.4-1+ubuntu19.04.1+deb.sury.org

Post by sudoranger » 2019-04-22T20:57:35-07:00

I'm sorry, I was in a rush when I posted this earlier on and didn't notice the ImageMagick vs Imagick spelling difference thus thinking they were the same things. Would someone move this thread to the appropriate subforum. Thanks!

Oh yes, imagemagick was already installed but php-imagick is not enabled even though already installed too. As of now, I'm not sure where the problem originates because there are too many dependencies/repos/parties involve...

Code: Select all

sudo apt install imagemagick
Reading package lists... Done
Building dependency tree       
Reading state information... Done
imagemagick is already the newest version (8:6.9.10.14+dfsg-7ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Post Reply